Author Topic: Installation of GeoliteCity - errors, how to proceed  (Read 1794 times)

0 Members and 1 Guest are viewing this topic.

smokinjo

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Installation of GeoliteCity - errors, how to proceed
« on: October 14, 2012, 06:33:30 AM »
Hello,

I have started using StatComm.

Very good so far.  But, I came across a feature that you can install. 

GeoliteCity

But, I can not succeed in installing the add-on.

Here are the line of message that I get:

2012-10-14 12:25:37 PM - Preparing a first time install of the Maxmind GeoLiteCity database
2012-10-14 12:25:37 PM - PHP Memory Limit is 256M, increasing is not needed.
2012-10-14 12:25:37 PM - GeoliteCity size is about 10 MB.
2012-10-14 12:25:37 PM - The download time depends on your server download speed.
2012-10-14 12:25:37 PM - A timeout can happen if the download takes more than 2 minutes.
2012-10-14 12:25:37 PM - Getting file from server...
2012-10-14 12:26:01 PM - Done. Saving gzip file to disk...
2012-10-14 12:26:01 PM - Could not save gzip file to disk or file not found. Permissions problems?

Can anyone point me in the right direction?  Is it a permission problem?  If so, where is the file being downloaded to, and I will correct the permissions.

Thanks!

Joe

forumadmin

  • Administrator
  • Jr. Member
  • *****
  • Posts: 92
  • Karma: +1/-0
    • View Profile
    • Wordpress Ready
Re: Installation of GeoliteCity - errors, how to proceed
« Reply #1 on: October 15, 2012, 06:24:11 AM »
Hi smokinjo,

The plugin has a subfolder named def where the GeoliteCity database is uncompressed. That folder needs to be writable.
This is also mentioned on the Help (see the Help->FAQ) but setting to 777 has some risks. You should adjust permissions according your needs.

See this link

http://forums.spry.com/plesk/1055-set-folder-permission-allow-apache-write-access.html