StatPress Community Forum > Troubleshooting

Export function in StatComm

(1/1)

ThornstromBlog:
Hi guys,
I've used the export functionality for the first time today. I tried to export month of June and I keep receiving Server Errors.

First time I tried I used the following dates 20120601 - 20120631 and I got an error. I thought, ah just 30 days in June.

Second: 20120601 - 20120630 still got an error.

Third: 20120601 - 20120615 and it worked

Fourth: 20120616 - 20120630 also worked.

So, as you can see I can get out the data I need so no major issues but would like you to know that there are some strange things going on in the Export function.

Take care and keep up the good work.
If you need me to dive into this or if you need more information from, please let me know and I will help.

I use:
Wordpress 3.4.1
StatComm 1.7.20
//PT

forumadmin:
Hi Thornstromg Blog, thanks for your comments.
Could you please tell us if you receive an error message?

We found that export function isn't working when the data is big (more than 10MB), but also in some scenarios it seems to fail completely delivering an empty file no errors attached.  :( Is that your case?

We also think we could improve some limitation in the fields format, current solution is hardcoded and requires a 'make-up'   :P
We are working to solve those errors, we hope we deliver a solution in the incoming 1.7.30 version.

Thank you for pointing out.
Best regards
Fernando

ThornstromBlog:
I receive follwoing Error:
Error 6 (net::ERR_FILE_NOT_FOUND): The file or directory could not be found.

The file size for June is 2,647 KB in CSV format.

I also noticed a spelling error in the result file: you have a theat_score and threat_type. I guess that would be threat_score.

//PT

forumadmin:
You are right about the misspelling, that is something we'll fix.
Thanks for the information about the error that was a case we couldn't reproduce, now we are aware of it.

Best regards
Fernando

forumadmin:
We polished the export tool in version 1.7.30. It should be work as expected.
Give it a try.
Best regards
Fernando

Navigation

[0] Message Index

Go to full version